$re = '#<bs-icon (?<attr>[^>]+)></bs-icon>#m';
$str = '<bs-icon class="bi" icon="book-half" title="My Icon Title"></bs-icon>
<bs-icon class="bi" icon="book-half" title="My Icon Title"></bs-icon>';
$subst = "<svg $1></svg>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;