using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((\d{1,3}(?:\s\d{3})*)\)";
string input = @"National Museum 4.6(1 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
National Museum 4.6(12 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
National Museum 4.6(686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}