use strict;
my $str = 'National Museum 4.6(1 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
National Museum 4.6(12 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
National Museum 4.6(686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
';
my $regex = qr/\((\d{1,3}(?:\s\d{3})*)\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}