import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((\\d{1,3}(?:\\s\\d{3})*)\\)";
final String string = "National Museum 4.6(1 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00\n"
+ "National Museum 4.6(12 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00\n"
+ "National Museum 4.6(686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}