// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\((\d{1,3}(?:\s\d{3})*)\)").unwrap();
let string = "National Museum 4.6(1 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
National Museum 4.6(12 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
National Museum 4.6(686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}