package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((\d{1,3}(?:\s\d{3})*)\)`)
var str = `National Museum 4.6(1 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
National Museum 4.6(12 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
National Museum 4.6(686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}