using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^AB_INV_[0-4](?!\d)";
string input = @"AB_INV_23_some_value
AB_INV_5_some_value
AB_INV_4_some_value
AB_INV_3_some_value
AB_INV_2_some_value
AB_INV_1_some_value
AB_INV_0_some_value";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}