import re
regex = re.compile(r"^AB_INV_[0-4](?!\d)", flags=re.MULTILINE)
test_str = ("AB_INV_23_some_value\n"
"AB_INV_5_some_value\n"
"AB_INV_4_some_value\n"
"AB_INV_3_some_value\n"
"AB_INV_2_some_value\n"
"AB_INV_1_some_value\n"
"AB_INV_0_some_value")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")