re = /^AB_INV_[0-4](?!\d)/m
str = 'AB_INV_23_some_value
AB_INV_5_some_value
AB_INV_4_some_value
AB_INV_3_some_value
AB_INV_2_some_value
AB_INV_1_some_value
AB_INV_0_some_value'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end