const regex = /^AB_INV_[0-4](?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^AB_INV_[0-4](?!\\d)', 'gm')
const str = `AB_INV_23_some_value
AB_INV_5_some_value
AB_INV_4_some_value
AB_INV_3_some_value
AB_INV_2_some_value
AB_INV_1_some_value
AB_INV_0_some_value`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}