import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^AB_INV_[0-4](?!\\d)";
final String string = "AB_INV_23_some_value\n"
+ "AB_INV_5_some_value\n"
+ "AB_INV_4_some_value\n"
+ "AB_INV_3_some_value\n"
+ "AB_INV_2_some_value\n"
+ "AB_INV_1_some_value\n"
+ "AB_INV_0_some_value";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}