$re = '/^AB_INV_[0-4](?!\d)/m';
$str = 'AB_INV_23_some_value
AB_INV_5_some_value
AB_INV_4_some_value
AB_INV_3_some_value
AB_INV_2_some_value
AB_INV_1_some_value
AB_INV_0_some_value';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);