package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+?$`)
var str = `Here is some text.
After several lines of whitespace, here is some more text.`
var substitution = "<line break>"
fmt.Println(re.ReplaceAllString(str, substitution))
}