import re
regex = re.compile(r"^\s+?$", flags=re.MULTILINE)
test_str = ("Here is some text.\n"
" \n"
" \n"
" \n"
" \n"
" \n"
"After several lines of whitespace, here is some more text.")
subst = "<line break>"
result = regex.sub(subst, test_str)
if result:
print(result)