re = /^\s+?$/m
str = 'Here is some text.
After several lines of whitespace, here is some more text.'
subst = '<line break>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result