const regex = /^\s+?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s+?$', 'gm')
const str = `Here is some text.
After several lines of whitespace, here is some more text.`;
const subst = `<line break>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);