import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s+?$";
final String string = "Here is some text.\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "After several lines of whitespace, here is some more text.";
final String subst = "<line break>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}