#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)AM19\/0[6-8][0-9][0-24-9]"
Local $sString = "AM19/0601" & @CRLF & _
"AM19/0805" & @CRLF & _
"AM19/0803" & @CRLF & _
" AM19/0601,AM19/0602,AM19/0803"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")