$re = '/AM19\/0[6-8][0-9][0-24-9]/m';
$str = 'AM19/0601
AM19/0805
AM19/0803
AM19/0601,AM19/0602,AM19/0803';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);