import re
regex = re.compile(r"AM19\/0[6-8][0-9][0-24-9]", flags=re.MULTILINE)
test_str = ("AM19/0601\n"
"AM19/0805\n"
"AM19/0803\n"
" AM19/0601,AM19/0602,AM19/0803")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")