package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)AM19\/0[6-8][0-9][0-24-9]`)
var str = `AM19/0601
AM19/0805
AM19/0803
AM19/0601,AM19/0602,AM19/0803`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}