using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"AM19\/0[6-8][0-9][0-24-9]";
string input = @"AM19/0601
AM19/0805
AM19/0803
AM19/0601,AM19/0602,AM19/0803";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}