// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)AM19\/0[6-8][0-9][0-24-9]").unwrap();
let string = "AM19/0601
AM19/0805
AM19/0803
AM19/0601,AM19/0602,AM19/0803";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}