import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(ТП 2-2/250-Ф1-))\\d+(\\/\\d+)?";
final String string = "ТП 2-2/250-Ф1-1-2-НД(1)-Б\n"
+ "ТП 2-2/250-Ф1-3/32-3-НД(1)-Б\n"
+ "ТП 2-2/250-Ф1-26-Д\n"
+ "ТП 2-2/250-Ф1-72/23-Д";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}