import Foundation
let pattern = #"(?<=(ТП 2-2/250-Ф1-))\d+(\/\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ТП 2-2/250-Ф1-1-2-НД(1)-Б
ТП 2-2/250-Ф1-3/32-3-НД(1)-Б
ТП 2-2/250-Ф1-26-Д
ТП 2-2/250-Ф1-72/23-Д
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)