$re = '/(?<=(ТП 2-2/250-Ф1-))\d+(\/\d+)?/m';
$str = 'ТП 2-2/250-Ф1-1-2-НД(1)-Б
ТП 2-2/250-Ф1-3/32-3-НД(1)-Б
ТП 2-2/250-Ф1-26-Д
ТП 2-2/250-Ф1-72/23-Д';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);