import re
regex = re.compile(r"(?<=(ТП 2-2/250-Ф1-))\d+(\/\d+)?", flags=re.MULTILINE)
test_str = ("ТП 2-2/250-Ф1-1-2-НД(1)-Б\n"
"ТП 2-2/250-Ф1-3/32-3-НД(1)-Б\n"
"ТП 2-2/250-Ф1-26-Д\n"
"ТП 2-2/250-Ф1-72/23-Д")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")