use strict;
my $str = 'ТП 2-2/250-Ф1-1-2-НД(1)-Б
ТП 2-2/250-Ф1-3/32-3-НД(1)-Б
ТП 2-2/250-Ф1-26-Д
ТП 2-2/250-Ф1-72/23-Д';
my $regex = qr/(?<=(ТП 2-2/250-Ф1-))\d+(\/\d+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}