#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$='(.+).\)\?>(.+)<\?"
Local $sString = "<?if($USERNAME$='artemchalysh')?>26.09.2021<?endif?>" & @CRLF & _
"<?if($USERNAME$='mponomarenko821')?>17.09.2021<?endif?>" & @CRLF & _
"<?if($USERNAME$='yeqingwen082')?>14.09.2021<?endif?>" & @CRLF & _
"<?if($USERNAME$='разДва34234kjs你好')?>13.09.2021<?endif?>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")