// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\$='(.+).\)\?>(.+)<\?").unwrap();
let string = "<?if($USERNAME$='artemchalysh')?>26.09.2021<?endif?>
<?if($USERNAME$='mponomarenko821')?>17.09.2021<?endif?>
<?if($USERNAME$='yeqingwen082')?>14.09.2021<?endif?>
<?if($USERNAME$='разДва34234kjs你好')?>13.09.2021<?endif?>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}