const regex = /\$='(.+).\)\?>(.+)<\?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$=\'(.+).\\)\\?>(.+)<\\?', 'gm')
const str = `<?if(\$USERNAME\$='artemchalysh')?>26.09.2021<?endif?>
<?if(\$USERNAME\$='mponomarenko821')?>17.09.2021<?endif?>
<?if(\$USERNAME\$='yeqingwen082')?>14.09.2021<?endif?>
<?if(\$USERNAME\$='разДва34234kjs你好')?>13.09.2021<?endif?>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}