use strict;
my $str = '<?if($USERNAME$=\'artemchalysh\')?>26.09.2021<?endif?>
<?if($USERNAME$=\'mponomarenko821\')?>17.09.2021<?endif?>
<?if($USERNAME$=\'yeqingwen082\')?>14.09.2021<?endif?>
<?if($USERNAME$=\'разДва34234kjs你好\')?>13.09.2021<?endif?>';
my $regex = qr/\$='(.+).\)\?>(.+)<\?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}