import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$='(.+).\\)\\?>(.+)<\\?";
final String string = "<?if($USERNAME$='artemchalysh')?>26.09.2021<?endif?>\n"
+ "<?if($USERNAME$='mponomarenko821')?>17.09.2021<?endif?>\n"
+ "<?if($USERNAME$='yeqingwen082')?>14.09.2021<?endif?>\n"
+ "<?if($USERNAME$='разДва34234kjs你好')?>13.09.2021<?endif?>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}