package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$='(.+).\)\?>(.+)<\?`)
var str = `<?if($USERNAME$='artemchalysh')?>26.09.2021<?endif?>
<?if($USERNAME$='mponomarenko821')?>17.09.2021<?endif?>
<?if($USERNAME$='yeqingwen082')?>14.09.2021<?endif?>
<?if($USERNAME$='разДва34234kjs你好')?>13.09.2021<?endif?>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}