$re = '/\$=\'(.+).\)\?>(.+)<\?/m';
$str = '<?if($USERNAME$=\'artemchalysh\')?>26.09.2021<?endif?>
<?if($USERNAME$=\'mponomarenko821\')?>17.09.2021<?endif?>
<?if($USERNAME$=\'yeqingwen082\')?>14.09.2021<?endif?>
<?if($USERNAME$=\'разДва34234kjs你好\')?>13.09.2021<?endif?>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);