#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[IMG\]http:\/\/i64\.tinypic\.com\/(.*?)\[\/IMG\]"
Local $sString = "[IMG]http://i64.tinypic.com/2zgg086.jpg[/IMG]" & @CRLF & _
"" & @CRLF & _
"[IMG]http://i64.nottinypic.com/2zgg086.jpg[/IMG]" & @CRLF & _
"" & @CRLF & _
"[IMG]http://i64.tinypic.com/2zgg0cdsc86.jpg[/IMG]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[img]http://i64.tinypic.com/2zgg086.jpg[/IMG]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")