package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[IMG\]http:\/\/i64\.tinypic\.com\/(.*?)\[\/IMG\]`)
var str = `[IMG]http://i64.tinypic.com/2zgg086.jpg[/IMG]
[IMG]http://i64.nottinypic.com/2zgg086.jpg[/IMG]
[IMG]http://i64.tinypic.com/2zgg0cdsc86.jpg[/IMG]
[img]http://i64.tinypic.com/2zgg086.jpg[/IMG]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}