// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\[IMG\]http:\/\/i64\.tinypic\.com\/(.*?)\[\/IMG\]").unwrap();
let string = "[IMG]http://i64.tinypic.com/2zgg086.jpg[/IMG]
[IMG]http://i64.nottinypic.com/2zgg086.jpg[/IMG]
[IMG]http://i64.tinypic.com/2zgg0cdsc86.jpg[/IMG]
[img]http://i64.tinypic.com/2zgg086.jpg[/IMG]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}