import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[IMG\\]http:\\/\\/i64\\.tinypic\\.com\\/(.*?)\\[\\/IMG\\]";
final String string = "[IMG]http://i64.tinypic.com/2zgg086.jpg[/IMG]\n\n"
+ "[IMG]http://i64.nottinypic.com/2zgg086.jpg[/IMG]\n\n"
+ "[IMG]http://i64.tinypic.com/2zgg0cdsc86.jpg[/IMG]\n\n\n"
+ "[img]http://i64.tinypic.com/2zgg086.jpg[/IMG]\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}