const regex = /\[IMG\]http:\/\/i64\.tinypic\.com\/(.*?)\[\/IMG\]/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[IMG\\]http:\\\/\\\/i64\\.tinypic\\.com\\\/(.*?)\\[\\\/IMG\\]', 'ig')
const str = `[IMG]http://i64.tinypic.com/2zgg086.jpg[/IMG]
[IMG]http://i64.nottinypic.com/2zgg086.jpg[/IMG]
[IMG]http://i64.tinypic.com/2zgg0cdsc86.jpg[/IMG]
[img]http://i64.tinypic.com/2zgg086.jpg[/IMG]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}