$re = '/\[IMG\]http:\/\/i64\.tinypic\.com\/(.*?)\[\/IMG\]/i';
$str = '[IMG]http://i64.tinypic.com/2zgg086.jpg[/IMG]
[IMG]http://i64.nottinypic.com/2zgg086.jpg[/IMG]
[IMG]http://i64.tinypic.com/2zgg0cdsc86.jpg[/IMG]
[img]http://i64.tinypic.com/2zgg086.jpg[/IMG]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);