# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i).*?\bfloor area:?\s*(\d+).*/\1/g;t' <<< "A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift
Newbuild flat. Floor Area: 30 sq.m\",\"6 bed house with floor area 50 sqm, lot area 25 sqm
6 bed house with floor area 50 sqm, lot area 25 sqm"