const regex = /(?i).*?\bfloor area:?\s*(\d+).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i).*?\\bfloor area:?\\s*(\\d+).*', 'g')
const str = `A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift
Newbuild flat. Floor Area: 30 sq.m","6 bed house with floor area 50 sqm, lot area 25 sqm
6 bed house with floor area 50 sqm, lot area 25 sqm`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);