re = /(?i).*?\bfloor area:?\s*(\d+).*/
str = 'A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift
Newbuild flat. Floor Area: 30 sq.m","6 bed house with floor area 50 sqm, lot area 25 sqm
6 bed house with floor area 50 sqm, lot area 25 sqm'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result