import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i).*?\\bfloor area:?\\s*(\\d+).*";
final String string = "A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift\n"
+ "Newbuild flat. Floor Area: 30 sq.m\",\"6 bed house with floor area 50 sqm, lot area 25 sqm\n"
+ "6 bed house with floor area 50 sqm, lot area 25 sqm";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}