#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i).*?\bfloor area:?\s*(\d+).*"
Local $sString = "A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift" & @CRLF & _
"Newbuild flat. Floor Area: 30 sq.m","6 bed house with floor area 50 sqm, lot area 25 sqm" & @CRLF & _
"6 bed house with floor area 50 sqm, lot area 25 sqm"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)