using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i).*?\bfloor area:?\s*(\d+).*";
string substitution = @"\1";
string input = @"A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift
Newbuild flat. Floor Area: 30 sq.m"",""6 bed house with floor area 50 sqm, lot area 25 sqm
6 bed house with floor area 50 sqm, lot area 25 sqm";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}