# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<(\w+)(?:\\/|.*?)>)((\w+\s?)+)(<(?:\\/|)\2+>)/$1{{ __("$3") }}$5/gm;t' <<< "'<a class=\"class\">' . $variable . '</a>'
\"<a class=\"class\">\" . $variable . \"</a>\"
<a class=\"class\">{{ $variable }}</a>
<a class=\"class\">{{ __(\"words\") }}</a>
<a class=\"class\">some words</a>
<a/>some words<a>
<a/>some words</a>
<a/></a>
<a>Some words</a>
<a><a>Some words</a></a>"