re = /(<(\w+)(?:\/|.*?)>)((\w+\s?)+)(<(?:\/|)\2+>)/m
str = '\'<a class="class">\' . $variable . \'</a>\'
"<a class="class">" . $variable . "</a>"
<a class="class">{{ $variable }}</a>
<a class="class">{{ __("words") }}</a>
<a class="class">some words</a>
<a/>some words<a>
<a/>some words</a>
<a/></a>
<a>Some words</a>
<a><a>Some words</a></a>'
subst = '$1{{ __("$3") }}$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result