using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<(\w+)(?:\/|.*?)>)((\w+\s?)+)(<(?:\/|)\2+>)";
string substitution = @"$1{{ __(""$3"") }}$5";
string input = @"'<a class=""class"">' . $variable . '</a>'
""<a class=""class"">"" . $variable . ""</a>""
<a class=""class"">{{ $variable }}</a>
<a class=""class"">{{ __(""words"") }}</a>
<a class=""class"">some words</a>
<a/>some words<a>
<a/>some words</a>
<a/></a>
<a>Some words</a>
<a><a>Some words</a></a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}